[framework] Problem between 2.5 and 3 Alpha 2 - dcom_ms03_026

Christian Liesegang masterl_dae at gmx.de
Mon Jan 16 13:50:15 CST 2006

, during the last weeks I experimented with the 2.5 framework using the 
windows version and exploited
successfully a window 2000 in a virtual machine. Now I set up a Suse 10 
in a Virual Maschine, too. I tried
to play around with the Framework 3.0 and tried the same exploit 
(dcom_ms03_026) on the same w2k box from the SuSE 10, but this time I got:
[*] Started reverse handler
[*] Trying target Windows NT SP3-6a/2000/XP/2003 Universal...
[*] Binding to 
4d9f4ab8-7d1c-11cf-861e-0020af6e7c57:0.0 at ncacn_ip_tcp:[135] ...
[*] Bound to 
4d9f4ab8-7d1c-11cf-861e-0020af6e7c57:0.0 at ncacn_ip_tcp:[135] ...
[*] sending exploit ...
[-] Exploit failed: DCERPC FAULT => 0x000006f7

My SuSE Box comes with Ruby 1.8.2 so I think it should work. While the 
3.0 fails, I could exploit with the 2.5 again and again.
I would be very thankful if someone could give my a hint.


More information about the framework mailing list